mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
107 lines
2.9 KiB
Diff
107 lines
2.9 KiB
Diff
--- xpcom/glue/nsBaseHashtable.h 2009-05-02 17:43:39.000000000 +0100
|
|
+++ xpcom/glue/nsBaseHashtable.h 2012-07-27 13:43:55.000000000 +0100
|
|
@@ -123,7 +123,7 @@
|
|
*/
|
|
PRBool Get(KeyType aKey, UserDataType* pData) const
|
|
{
|
|
- EntryType* ent = GetEntry(aKey);
|
|
+ EntryType* ent = this->GetEntry(aKey);
|
|
|
|
if (!ent)
|
|
return PR_FALSE;
|
|
@@ -142,7 +142,7 @@
|
|
*/
|
|
PRBool Put(KeyType aKey, UserDataType aData)
|
|
{
|
|
- EntryType* ent = PutEntry(aKey);
|
|
+ EntryType* ent = this->PutEntry(aKey);
|
|
|
|
if (!ent)
|
|
return PR_FALSE;
|
|
@@ -156,7 +156,7 @@
|
|
* remove the data for the associated key
|
|
* @param aKey the key to remove from the hashtable
|
|
*/
|
|
- void Remove(KeyType aKey) { RemoveEntry(aKey); }
|
|
+ void Remove(KeyType aKey) { this->RemoveEntry(aKey); }
|
|
|
|
/**
|
|
* function type provided by the application for enumeration.
|
|
--- xpcom/glue/nsClassHashtable.h 2009-05-02 17:43:39.000000000 +0100
|
|
+++ xpcom/glue/nsClassHashtable.h 2012-07-27 13:15:10.000000000 +0100
|
|
@@ -98,7 +98,7 @@
|
|
nsClassHashtable<KeyClass,T>::Get(KeyType aKey, T** retVal) const
|
|
{
|
|
typename nsBaseHashtable<KeyClass,nsAutoPtr<T>,T*>::EntryType* ent =
|
|
- GetEntry(aKey);
|
|
+ this->GetEntry(aKey);
|
|
|
|
if (ent)
|
|
{
|
|
@@ -126,7 +126,7 @@
|
|
PR_Lock(this->mLock);
|
|
|
|
typename nsBaseHashtableMT<KeyClass,nsAutoPtr<T>,T*>::EntryType* ent =
|
|
- GetEntry(aKey);
|
|
+ this->GetEntry(aKey);
|
|
|
|
if (ent)
|
|
{
|
|
--- xpcom/glue/nsInterfaceHashtable.h 2009-05-02 17:43:39.000000000 +0100
|
|
+++ xpcom/glue/nsInterfaceHashtable.h 2012-07-27 13:30:08.000000000 +0100
|
|
@@ -111,7 +111,7 @@
|
|
(KeyType aKey, UserDataType* pInterface) const
|
|
{
|
|
typename nsBaseHashtable<KeyClass, nsCOMPtr<Interface>, Interface*>::EntryType* ent =
|
|
- GetEntry(aKey);
|
|
+ this->GetEntry(aKey);
|
|
|
|
if (ent)
|
|
{
|
|
@@ -139,7 +139,7 @@
|
|
(KeyType aKey, PRBool* aFound) const
|
|
{
|
|
typename nsBaseHashtable<KeyClass, nsCOMPtr<Interface>, Interface*>::EntryType* ent =
|
|
- GetEntry(aKey);
|
|
+ this->GetEntry(aKey);
|
|
|
|
if (ent)
|
|
{
|
|
@@ -167,7 +167,7 @@
|
|
PR_Lock(this->mLock);
|
|
|
|
typename nsBaseHashtableMT<KeyClass, nsCOMPtr<Interface>, Interface*>::EntryType* ent =
|
|
- GetEntry(aKey);
|
|
+ this->GetEntry(aKey);
|
|
|
|
if (ent)
|
|
{
|
|
--- xpcom/glue/nsRefPtrHashtable.h 2009-05-02 17:43:39.000000000 +0100
|
|
+++ xpcom/glue/nsRefPtrHashtable.h 2012-07-27 13:52:48.000000000 +0100
|
|
@@ -112,7 +112,7 @@
|
|
(KeyType aKey, UserDataType* pRefPtr) const
|
|
{
|
|
typename nsBaseHashtable<KeyClass, nsRefPtr<RefPtr>, RefPtr*>::EntryType* ent =
|
|
- GetEntry(aKey);
|
|
+ this->GetEntry(aKey);
|
|
|
|
if (ent)
|
|
{
|
|
@@ -140,7 +140,7 @@
|
|
(KeyType aKey, PRBool* aFound) const
|
|
{
|
|
typename nsBaseHashtable<KeyClass, nsRefPtr<RefPtr>, RefPtr*>::EntryType* ent =
|
|
- GetEntry(aKey);
|
|
+ this->GetEntry(aKey);
|
|
|
|
if (ent)
|
|
{
|
|
@@ -168,7 +168,7 @@
|
|
PR_Lock(this->mLock);
|
|
|
|
typename nsBaseHashtableMT<KeyClass, nsRefPtr<RefPtr>, RefPtr*>::EntryType* ent =
|
|
- GetEntry(aKey);
|
|
+ this->GetEntry(aKey);
|
|
|
|
if (ent)
|
|
{
|