mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
62 lines
2.5 KiB
Diff
62 lines
2.5 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
|
|
Date: Fri, 3 Mar 2023 16:46:35 +0000
|
|
Subject: [PATCH] zxing: update to 2.0.0 tag
|
|
|
|
---
|
|
subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp | 4 ++--
|
|
subprojects/gst-plugins-bad/ext/zxing/meson.build | 2 +-
|
|
2 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp b/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
|
|
index 7836dbbcf18e..a7a24168383f 100644
|
|
--- a/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
|
|
+++ b/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
|
|
@@ -369,32 +369,32 @@ gst_zxing_transform_frame_ip (GstVideoFilter * vfilter, GstVideoFrame * frame)
|
|
if (result.isValid ()) {
|
|
GST_DEBUG_OBJECT (zxing, "Symbol found. Text: %s Format: %s",
|
|
result.text ().c_str (),
|
|
- ToString (result.format ()));
|
|
+ ToString (result.format ()).c_str ());
|
|
} else {
|
|
goto out;
|
|
}
|
|
|
|
/* extract results */
|
|
if (zxing->message) {
|
|
GstMessage *m;
|
|
GstStructure *s;
|
|
GstSample *sample;
|
|
GstCaps *sample_caps;
|
|
GstClockTime timestamp, running_time, stream_time;
|
|
|
|
timestamp = GST_BUFFER_TIMESTAMP (frame->buffer);
|
|
running_time =
|
|
gst_segment_to_running_time (&GST_BASE_TRANSFORM (zxing)->segment,
|
|
GST_FORMAT_TIME, timestamp);
|
|
stream_time =
|
|
gst_segment_to_stream_time (&GST_BASE_TRANSFORM (zxing)->segment,
|
|
GST_FORMAT_TIME, timestamp);
|
|
|
|
s = gst_structure_new ("barcode",
|
|
"timestamp", G_TYPE_UINT64, timestamp,
|
|
"stream-time", G_TYPE_UINT64, stream_time,
|
|
"running-time", G_TYPE_UINT64, running_time,
|
|
- "type", G_TYPE_STRING, ToString (result.format ()),
|
|
+ "type", G_TYPE_STRING, ToString (result.format ()).c_str (),
|
|
"symbol", G_TYPE_STRING,
|
|
result.text ().c_str (), NULL);
|
|
|
|
diff --git a/subprojects/gst-plugins-bad/ext/zxing/meson.build b/subprojects/gst-plugins-bad/ext/zxing/meson.build
|
|
index 2dbad9ab1eea..89e1f6592e7a 100644
|
|
--- a/subprojects/gst-plugins-bad/ext/zxing/meson.build
|
|
+++ b/subprojects/gst-plugins-bad/ext/zxing/meson.build
|
|
@@ -2,7 +2,7 @@ zxing_sources = [
|
|
'gstzxing.cpp',
|
|
'gstzxingplugin.c',
|
|
]
|
|
-zxing_dep = dependency('zxing', version : '>= 1.4.0', required : get_option('zxing'))
|
|
+zxing_dep = dependency('zxing', version : '>= 2.0.0', required : get_option('zxing'))
|
|
if zxing_dep.found()
|
|
gstzxing = library('gstzxing',
|
|
zxing_sources,
|