mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
43 lines
1.1 KiB
Diff
43 lines
1.1 KiB
Diff
From b5553dc73dcf40b1cf1c3114278706526c386956 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Wed, 3 Feb 2016 20:59:26 -0700
|
|
Subject: [PATCH 1/2] sd_fusing tweaks
|
|
|
|
---
|
|
sd_fuse/sd_fusing.sh | 13 ++++++-------
|
|
1 file changed, 6 insertions(+), 7 deletions(-)
|
|
|
|
diff --git a/sd_fuse/sd_fusing.sh b/sd_fuse/sd_fusing.sh
|
|
index 538185b..c14e0e2 100755
|
|
--- a/sd_fuse/sd_fusing.sh
|
|
+++ b/sd_fuse/sd_fusing.sh
|
|
@@ -15,20 +15,19 @@ if [ -z $1 ]; then
|
|
fi
|
|
|
|
if [ ! -f $BL1 ]; then
|
|
- echo "error: $BL1 is not exist"
|
|
+ echo "error: $BL1 does not exist"
|
|
exit 1
|
|
fi
|
|
|
|
if [ ! -f $UBOOT ]; then
|
|
- echo "error: $UBOOT is not exist"
|
|
+ echo "error: $UBOOT does not exist"
|
|
exit 1
|
|
fi
|
|
|
|
-sudo dd if=$BL1 of=$1 conv=fsync bs=1 count=442
|
|
-sudo dd if=$BL1 of=$1 conv=fsync bs=512 skip=1 seek=1
|
|
-sudo dd if=$UBOOT of=$1 conv=fsync bs=512 seek=97
|
|
+dd if=$BL1 of=$1 conv=fsync bs=1 count=442
|
|
+dd if=$BL1 of=$1 conv=fsync bs=512 skip=1 seek=1
|
|
+dd if=$UBOOT of=$1 conv=fsync bs=512 seek=97
|
|
|
|
sync
|
|
|
|
-sudo eject $1
|
|
-echo Finished.
|
|
+echo "Successfully wrote U-Boot to $1"
|
|
--
|
|
2.8.0
|
|
|