mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
24 lines
946 B
Diff
24 lines
946 B
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
Date: Sat, 6 Nov 2021 22:42:06 +0100
|
|
Subject: [PATCH] compiler: Use wasm-ld for wasm targets
|
|
|
|
We don't ship rust-lld.
|
|
---
|
|
compiler/rustc_target/src/spec/wasm_base.rs | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
diff --git a/compiler/rustc_target/src/spec/wasm_base.rs b/compiler/rustc_target/src/spec/wasm_base.rs
|
|
index 528a84a8b37c..f8af062bc2b1 100644
|
|
--- a/compiler/rustc_target/src/spec/wasm_base.rs
|
|
+++ b/compiler/rustc_target/src/spec/wasm_base.rs
|
|
@@ -89,8 +89,7 @@ macro_rules! args {
|
|
// arguments just yet
|
|
limit_rdylib_exports: false,
|
|
|
|
- // we use the LLD shipped with the Rust toolchain by default
|
|
- linker: Some("rust-lld".into()),
|
|
+ linker: Some("wasm-ld".into()),
|
|
linker_flavor: LinkerFlavor::WasmLld(Cc::No),
|
|
|
|
pre_link_args,
|