mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
67 lines
2.3 KiB
Diff
67 lines
2.3 KiB
Diff
diff --git a/filters/karbon/pdf/PdfImport.cpp b/filters/karbon/pdf/PdfImport.cpp
|
|
index c3e96b0cd28..48b08dfa32d 100644
|
|
--- a/filters/karbon/pdf/PdfImport.cpp
|
|
+++ b/filters/karbon/pdf/PdfImport.cpp
|
|
@@ -102,9 +102,6 @@ KoFilter::ConversionStatus PdfImport::convert(const QByteArray& from, const QByt
|
|
delete globalParams;
|
|
globalParams = 0;
|
|
|
|
- // check for memory leaks
|
|
- Object::memCheck(stderr);
|
|
-
|
|
return KoFilter::OK;
|
|
}
|
|
|
|
diff --git a/filters/karbon/pdf/SvgOutputDev.cpp b/filters/karbon/pdf/SvgOutputDev.cpp
|
|
index 931917ae15d..7901317ebd0 100644
|
|
--- a/filters/karbon/pdf/SvgOutputDev.cpp
|
|
+++ b/filters/karbon/pdf/SvgOutputDev.cpp
|
|
@@ -212,7 +212,7 @@ QString SvgOutputDev::convertMatrix(const QMatrix &matrix)
|
|
.arg(matrix.dx()) .arg(matrix.dy());
|
|
}
|
|
|
|
-QString SvgOutputDev::convertMatrix(double * matrix)
|
|
+QString SvgOutputDev::convertMatrix(const double * matrix)
|
|
{
|
|
return QString("matrix(%1 %2 %3 %4 %5 %6)")
|
|
.arg(matrix[0]).arg(matrix[1])
|
|
@@ -402,7 +402,7 @@ void SvgOutputDev::drawString(GfxState * state, GooString * s)
|
|
|
|
QString str;
|
|
|
|
- char * p = s->getCString();
|
|
+ const char * p = s->getCString();
|
|
int len = s->getLength();
|
|
CharCode code;
|
|
Unicode *u = nullptr;
|
|
@@ -429,7 +429,7 @@ void SvgOutputDev::drawString(GfxState * state, GooString * s)
|
|
double x = state->getCurX();
|
|
double y = state->getCurY();
|
|
|
|
- double * ctm = state->getCTM();
|
|
+ const double * ctm = state->getCTM();
|
|
QMatrix transform(ctm[0], ctm[1], ctm[2], ctm[3], ctm[4], ctm[5]);
|
|
|
|
QMatrix mirror;
|
|
@@ -522,7 +522,7 @@ void SvgOutputDev::drawImage(GfxState *state, Object */*ref*/, Stream *str,
|
|
return;
|
|
}
|
|
|
|
- double * ctm = state->getCTM();
|
|
+ const double * ctm = state->getCTM();
|
|
QMatrix m;
|
|
m.setMatrix(ctm[0] / width, ctm[1] / width, -ctm[2] / height, -ctm[3] / height, ctm[2] + ctm[4], ctm[3] + ctm[5]);
|
|
|
|
diff --git a/filters/karbon/pdf/SvgOutputDev.h b/filters/karbon/pdf/SvgOutputDev.h
|
|
index 85fe55dfff6..2a4490848bf 100644
|
|
--- a/filters/karbon/pdf/SvgOutputDev.h
|
|
+++ b/filters/karbon/pdf/SvgOutputDev.h
|
|
@@ -84,7 +84,7 @@ public:
|
|
private:
|
|
QString convertPath(GfxPath *path);
|
|
QString convertMatrix(const QMatrix &matrix);
|
|
- QString convertMatrix(double * matrix);
|
|
+ QString convertMatrix(const double * matrix);
|
|
QString printFill();
|
|
QString printStroke();
|
|
|