PKGBUILDs/extra/flatpak/0001-HACK-Use-fusermount3.patch
2023-11-18 21:04:11 +00:00

78 lines
2.7 KiB
Diff

From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Tue, 14 Nov 2023 21:43:21 +0100
Subject: [PATCH] HACK: Use fusermount3
---
common/flatpak-dir.c | 2 +-
tests/can-use-fuse.c | 6 +++---
tests/libtest.sh | 4 ++--
3 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/common/flatpak-dir.c b/common/flatpak-dir.c
index f6a2f872a335..82c06381450b 100644
--- a/common/flatpak-dir.c
+++ b/common/flatpak-dir.c
@@ -2110,7 +2110,7 @@ flatpak_dir_revokefs_fuse_unmount (OstreeRepo **repo,
fusermount = g_subprocess_new (G_SUBPROCESS_FLAGS_NONE,
error,
- "fusermount", "-u", "-z", mnt_dir,
+ "fusermount3", "-u", "-z", mnt_dir,
NULL);
if (g_subprocess_wait_check (fusermount, NULL, error))
{
diff --git a/tests/can-use-fuse.c b/tests/can-use-fuse.c
index fb6e20003102..759f0d842c6c 100644
--- a/tests/can-use-fuse.c
+++ b/tests/can-use-fuse.c
@@ -53,23 +53,23 @@ check_fuse (void)
return FALSE;
}
- fusermount = g_find_program_in_path ("fusermount");
+ fusermount = g_find_program_in_path ("fusermount3");
if (fusermount == NULL)
{
- cannot_use_fuse = g_strdup ("fusermount not found in PATH");
+ cannot_use_fuse = g_strdup ("fusermount3 not found in PATH");
return FALSE;
}
if (!g_file_test (fusermount, G_FILE_TEST_IS_EXECUTABLE))
{
cannot_use_fuse = g_strdup_printf ("%s not executable", fusermount);
return FALSE;
}
if (!g_file_test ("/etc/mtab", G_FILE_TEST_EXISTS))
{
- cannot_use_fuse = g_strdup ("fusermount won't work without /etc/mtab");
+ cannot_use_fuse = g_strdup ("fusermount3 won't work without /etc/mtab");
return FALSE;
}
diff --git a/tests/libtest.sh b/tests/libtest.sh
index 36d39ac4deb7..e78d94ca525a 100644
--- a/tests/libtest.sh
+++ b/tests/libtest.sh
@@ -542,7 +542,7 @@ skip_one_without_bwrap () {
}
skip_without_fuse () {
- fusermount --version >/dev/null 2>&1 || skip "no fusermount"
+ fusermount3 --version >/dev/null 2>&1 || skip "no fusermount3"
capsh --print | grep -q 'Bounding set.*[^a-z]cap_sys_admin' || \
skip "No cap_sys_admin in bounding set, can't use FUSE"
@@ -608,7 +608,7 @@ commit_to_path () {
cleanup () {
/bin/kill -9 $DBUS_SESSION_BUS_PID
gpg-connect-agent --homedir "${FL_GPG_HOMEDIR}" killagent /bye >&2 || true
- fusermount -u $XDG_RUNTIME_DIR/doc >&2 || :
+ fusermount3 -u $XDG_RUNTIME_DIR/doc >&2 || :
kill $(jobs -p) &> /dev/null || true
if test -n "${TEST_SKIP_CLEANUP:-}"; then
echo "# Skipping cleanup of ${TEST_DATA_DIR}"