mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
65 lines
2.5 KiB
Diff
65 lines
2.5 KiB
Diff
From 42cebff14f7d486c20f04863681cc5ef4602f4eb Mon Sep 17 00:00:00 2001
|
|
From: Rene Engelhard <rene@debian.org>
|
|
Date: Tue, 24 Apr 2018 15:56:23 +0200
|
|
Subject: [PATCH] fix build with poppler 0.64
|
|
|
|
GooString became const...
|
|
|
|
Change-Id: Icc95be2e8603a4e22c6a9ac2008986bacd0bfba5
|
|
---
|
|
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 10 ++++++++++
|
|
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
|
|
2 files changed, 14 insertions(+)
|
|
|
|
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
|
index 48a735ba54a5..06e4faead383 100644
|
|
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
|
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
|
|
@@ -432,6 +432,9 @@ int PDFOutDev::parseFont( long long nNewId, GfxFont* gfxFont, GfxState* state )
|
|
FontAttributes aNewFont;
|
|
int nSize = 0;
|
|
|
|
+#if POPPLER_CHECK_VERSION(0, 64, 0)
|
|
+ const
|
|
+#endif
|
|
GooString* pFamily = gfxFont->getName();
|
|
if( pFamily )
|
|
{
|
|
@@ -728,6 +731,9 @@ void PDFOutDev::updateFont(GfxState *state)
|
|
FontAttributes aFont;
|
|
int nEmbedSize=0;
|
|
|
|
+#if POPPLER_CHECK_VERSION(0, 64, 0)
|
|
+ const
|
|
+#endif
|
|
Ref* pID = gfxFont->getID();
|
|
// TODO(Q3): Portability problem
|
|
long long fontID = static_cast<long long>(pID->gen) << 32 | static_cast<long long>(pID->num);
|
|
@@ -918,7 +924,11 @@ void PDFOutDev::drawChar(GfxState *state, double x, double y,
|
|
printf( "\n" );
|
|
}
|
|
|
|
+#if POPPLER_CHECK_VERSION(0, 64, 0)
|
|
+void PDFOutDev::drawString(GfxState*, const GooString* /*s*/)
|
|
+#else
|
|
void PDFOutDev::drawString(GfxState*, GooString* /*s*/)
|
|
+#endif
|
|
{
|
|
// TODO(F3): NYI
|
|
}
|
|
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
|
index c3367aa6ddf2..7e65f085d288 100644
|
|
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
|
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
|
|
@@ -224,7 +224,11 @@ namespace pdfi
|
|
double dx, double dy,
|
|
double originX, double originY,
|
|
CharCode code, int nBytes, Unicode *u, int uLen) override;
|
|
+#if POPPLER_CHECK_VERSION(0, 64, 0)
|
|
+ virtual void drawString(GfxState *state, const GooString *s) override;
|
|
+#else
|
|
virtual void drawString(GfxState *state, GooString *s) override;
|
|
+#endif
|
|
virtual void endTextObject(GfxState *state) override;
|
|
|
|
//----- image drawing
|