mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
21 lines
754 B
Diff
21 lines
754 B
Diff
From 12726cda009a855073b9bedbdce57b6ce7763da2 Mon Sep 17 00:00:00 2001
|
|
From: Peter Dimov <pdimov@pdimov.com>
|
|
Date: Sat, 2 Dec 2017 04:10:46 +0200
|
|
Subject: [PATCH] Add #include <boost/next_prior.hpp>; no longer in utility.hpp
|
|
|
|
---
|
|
include/boost/lockfree/spsc_queue.hpp | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/include/boost/lockfree/spsc_queue.hpp b/include/boost/lockfree/spsc_queue.hpp
|
|
index 7903d2c..c7f2953 100644
|
|
--- a/include/boost/lockfree/spsc_queue.hpp
|
|
+++ b/include/boost/lockfree/spsc_queue.hpp
|
|
@@ -17,6 +17,7 @@
|
|
#include <boost/assert.hpp>
|
|
#include <boost/static_assert.hpp>
|
|
#include <boost/utility.hpp>
|
|
+#include <boost/next_prior.hpp>
|
|
#include <boost/utility/enable_if.hpp>
|
|
#include <boost/config.hpp> // for BOOST_LIKELY
|
|
|