mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
22 lines
866 B
Diff
22 lines
866 B
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
|
|
Date: Thu, 6 May 2021 20:13:31 +0200
|
|
Subject: [PATCH] cargo: Change libexec dir
|
|
|
|
---
|
|
src/cargo/ops/registry/auth.rs | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/cargo/ops/registry/auth.rs b/src/cargo/ops/registry/auth.rs
|
|
index d10b1988e920..b58e05857233 100644
|
|
--- a/src/cargo/ops/registry/auth.rs
|
|
+++ b/src/cargo/ops/registry/auth.rs
|
|
@@ -223,7 +223,7 @@ fn sysroot_credential(
|
|
.parent()
|
|
.and_then(|p| p.parent())
|
|
.ok_or_else(|| format_err!("expected cargo path {}", cargo.display()))?;
|
|
- let exe = root.join("libexec").join(format!(
|
|
+ let exe = root.join("lib").join(format!(
|
|
"cargo-credential-{}{}",
|
|
cred_name,
|
|
std::env::consts::EXE_SUFFIX
|