mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
13 lines
510 B
Diff
13 lines
510 B
Diff
--- lib/core/include/Graph.h.orig 2017-03-28 03:30:14.000000000 -0600
|
|
+++ lib/core/include/Graph.h 2017-03-28 21:33:36.040286583 -0600
|
|
@@ -709,8 +709,8 @@ public:
|
|
void swap(Table& t)
|
|
{
|
|
std::swap(R,t.R);
|
|
- std::swap(node_maps, t.node_maps);
|
|
- std::swap(edge_maps, t.edge_maps);
|
|
+ node_maps.swap(t.node_maps);
|
|
+ edge_maps.swap(t.edge_maps);
|
|
std::swap(n_nodes, t.n_nodes);
|
|
std::swap(free_node_id, t.free_node_id);
|
|
std::swap(free_edge_ids, t.free_edge_ids);
|