mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
61 lines
2.4 KiB
Diff
61 lines
2.4 KiB
Diff
From a877c2568fc96a7a7ba89dd4cf0df20341df2a37 Mon Sep 17 00:00:00 2001
|
|
From: Ethan Tuttle <ethan@ethantuttle.com>
|
|
Date: Tue, 19 Jun 2018 21:31:08 -0700
|
|
Subject: [PATCH 14/14] ARM: mvebu: declare asm symbols as character arrays in
|
|
pmsu.c
|
|
|
|
With CONFIG_FORTIFY_SOURCE, memcpy uses the declared size of operands to
|
|
detect buffer overflows. If src or dest is declared as a char, attempts to
|
|
copy more than byte will result in a fortify_panic().
|
|
|
|
Address this problem in mvebu_setup_boot_addr_wa() by declaring
|
|
mvebu_boot_wa_start and mvebu_boot_wa_end as character arrays. Also remove
|
|
a couple addressof operators to avoid "arithmetic on pointer to an
|
|
incomplete type" compiler error.
|
|
|
|
See commit 54a7d50b9205 ("x86: mark kprobe templates as character arrays,
|
|
not single characters") for a similar fix.
|
|
|
|
Fixes "detected buffer overflow in memcpy" error during init on some mvebu
|
|
systems (armada-370-xp, armada-375):
|
|
|
|
(fortify_panic) from (mvebu_setup_boot_addr_wa+0xb0/0xb4)
|
|
(mvebu_setup_boot_addr_wa) from (mvebu_v7_cpu_pm_init+0x154/0x204)
|
|
(mvebu_v7_cpu_pm_init) from (do_one_initcall+0x7c/0x1a8)
|
|
(do_one_initcall) from (kernel_init_freeable+0x1bc/0x254)
|
|
(kernel_init_freeable) from (kernel_init+0x8/0x114)
|
|
(kernel_init) from (ret_from_fork+0x14/0x2c)
|
|
|
|
Signed-off-by: Ethan Tuttle <ethan@ethantuttle.com>
|
|
Tested-by: Ethan Tuttle <ethan@ethantuttle.com>
|
|
---
|
|
arch/arm/mach-mvebu/pmsu.c | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/arch/arm/mach-mvebu/pmsu.c b/arch/arm/mach-mvebu/pmsu.c
|
|
index 27a78c80e5b1..73d5d72dfc3e 100644
|
|
--- a/arch/arm/mach-mvebu/pmsu.c
|
|
+++ b/arch/arm/mach-mvebu/pmsu.c
|
|
@@ -116,8 +116,8 @@ void mvebu_pmsu_set_cpu_boot_addr(int hw_cpu, void *boot_addr)
|
|
PMSU_BOOT_ADDR_REDIRECT_OFFSET(hw_cpu));
|
|
}
|
|
|
|
-extern unsigned char mvebu_boot_wa_start;
|
|
-extern unsigned char mvebu_boot_wa_end;
|
|
+extern unsigned char mvebu_boot_wa_start[];
|
|
+extern unsigned char mvebu_boot_wa_end[];
|
|
|
|
/*
|
|
* This function sets up the boot address workaround needed for SMP
|
|
@@ -130,7 +130,7 @@ int mvebu_setup_boot_addr_wa(unsigned int crypto_eng_target,
|
|
phys_addr_t resume_addr_reg)
|
|
{
|
|
void __iomem *sram_virt_base;
|
|
- u32 code_len = &mvebu_boot_wa_end - &mvebu_boot_wa_start;
|
|
+ u32 code_len = mvebu_boot_wa_end - mvebu_boot_wa_start;
|
|
|
|
mvebu_mbus_del_window(BOOTROM_BASE, BOOTROM_SIZE);
|
|
mvebu_mbus_add_window_by_id(crypto_eng_target, crypto_eng_attribute,
|
|
--
|
|
2.18.0
|
|
|