mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
54 lines
1.8 KiB
Diff
54 lines
1.8 KiB
Diff
From 3ea8b43a40ae4c31c684d75a18d27961efa3aab1 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Wed, 16 Sep 2015 17:51:00 -0600
|
|
Subject: [PATCH] arm fixes
|
|
|
|
---
|
|
configure | 7 +++++--
|
|
deps/v8/build/toolchain.gypi | 4 ++--
|
|
2 files changed, 7 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configure b/configure
|
|
index 6c8dfde..cc7dbfa 100755
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -603,9 +603,12 @@ def configure_arm(o):
|
|
if is_arch_armv7():
|
|
o['variables']['arm_fpu'] = 'vfpv3'
|
|
o['variables']['arm_version'] = '7'
|
|
- else:
|
|
+ elif is_arch_armv6():
|
|
o['variables']['arm_fpu'] = 'vfpv2'
|
|
- o['variables']['arm_version'] = '6' if is_arch_armv6() else 'default'
|
|
+ o['variables']['arm_version'] = '6'
|
|
+ else:
|
|
+ o['variables']['arm_fpu'] = ''
|
|
+ o['variables']['arm_version'] = '5'
|
|
|
|
o['variables']['arm_thumb'] = 0 # -marm
|
|
o['variables']['arm_float_abi'] = arm_float_abi
|
|
diff --git a/deps/v8/build/toolchain.gypi b/deps/v8/build/toolchain.gypi
|
|
index 4dbf42b..8d3e968 100644
|
|
--- a/deps/v8/build/toolchain.gypi
|
|
+++ b/deps/v8/build/toolchain.gypi
|
|
@@ -203,7 +203,7 @@
|
|
}],
|
|
[ 'arm_version==7 or arm_version=="default"', {
|
|
'conditions': [
|
|
- [ 'arm_fpu!="default"', {
|
|
+ [ 'arm_fpu!="default" and arm_fpu!=""', {
|
|
'cflags': ['-mfpu=<(arm_fpu)',],
|
|
}],
|
|
],
|
|
@@ -246,7 +246,7 @@
|
|
}],
|
|
[ 'arm_version==7 or arm_version=="default"', {
|
|
'conditions': [
|
|
- [ 'arm_fpu!="default"', {
|
|
+ [ 'arm_fpu!="default" and arm_fpu!=""', {
|
|
'cflags': ['-mfpu=<(arm_fpu)',],
|
|
}],
|
|
],
|
|
--
|
|
2.5.2
|
|
|