mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
60 lines
2.2 KiB
Diff
60 lines
2.2 KiB
Diff
diff --git a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
|
|
index a0c41ac..e9a94f6 100644
|
|
--- a/include/configs/sunxi-common.h
|
|
+++ b/include/configs/sunxi-common.h
|
|
@@ -157,7 +157,7 @@
|
|
#define CONFIG_SYS_NO_FLASH
|
|
|
|
#define CONFIG_SYS_MONITOR_LEN (512 << 10) /* 512 KiB */
|
|
-#define CONFIG_IDENT_STRING " Allwinner Technology"
|
|
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
|
|
|
#define CONFIG_ENV_OFFSET (544 << 10) /* (8 + 24 + 512) KiB */
|
|
#define CONFIG_ENV_SIZE (128 << 10) /* 128 KiB */
|
|
@@ -215,38 +215,28 @@
|
|
"bootscr=boot.scr\0" \
|
|
"script=script.bin\0" \
|
|
"loadbootscr=" \
|
|
- "fatload $device $partition $scriptaddr ${bootscr}" \
|
|
- " || " \
|
|
- "ext2load $device $partition $scriptaddr boot/${bootscr}" \
|
|
+ "load $device $partition $scriptaddr boot/${bootscr}" \
|
|
" ||" \
|
|
- "ext2load $device $partition $scriptaddr ${bootscr}" \
|
|
+ "load $device $partition $scriptaddr ${bootscr}" \
|
|
"\0" \
|
|
"loadbootenv=" \
|
|
- "fatload $device $partition $scriptaddr ${bootenv}" \
|
|
- " || " \
|
|
- "ext2load $device $partition $scriptaddr boot/${bootenv}" \
|
|
+ "load $device $partition $scriptaddr boot/${bootenv}" \
|
|
" || " \
|
|
- "ext2load $device $partition $scriptaddr ${bootenv}" \
|
|
+ "load $device $partition $scriptaddr ${bootenv}" \
|
|
"\0" \
|
|
"loadkernel=" \
|
|
"if "\
|
|
"bootpath=/boot/" \
|
|
" && " \
|
|
- "ext2load $device $partition 0x43000000 ${bootpath}${script}" \
|
|
- " && " \
|
|
- "ext2load $device $partition 0x48000000 ${bootpath}${kernel}" \
|
|
- ";then true; elif " \
|
|
- "bootpath=/" \
|
|
- " && " \
|
|
- "fatload $device $partition 0x43000000 ${script}" \
|
|
+ "load $device $partition 0x43000000 ${bootpath}${script}" \
|
|
" && " \
|
|
- "fatload $device $partition 0x48000000 ${kernel}" \
|
|
+ "load $device $partition 0x48000000 ${bootpath}${kernel}" \
|
|
";then true; elif " \
|
|
"bootpath=/" \
|
|
" && " \
|
|
- "ext2load $device $partition 0x43000000 ${bootpath}${script}" \
|
|
+ "load $device $partition 0x43000000 ${bootpath}${script}" \
|
|
" && " \
|
|
- "ext2load $device $partition 0x48000000 ${bootpath}${kernel}" \
|
|
+ "load $device $partition 0x48000000 ${bootpath}${kernel}" \
|
|
";then true; else "\
|
|
"false" \
|
|
";fi" \
|