mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
Functional support for the Iteaduino A10 and Iteaduino A20.
This commit is contained in:
parent
034eab0cb7
commit
a963b74708
4 changed files with 1924 additions and 3000 deletions
|
@ -4,7 +4,7 @@
|
|||
buildarch=4
|
||||
|
||||
pkgbase=uboot-sunxi
|
||||
pkgname=('uboot-cubieboard2' 'uboot-cubietruck')
|
||||
pkgname=('uboot-cubieboard2' 'uboot-cubietruck' 'uboot-iteaduino_plus_a10' 'uboot-iteaduino_plus_a20')
|
||||
pkgver=2014.01
|
||||
pkgrel=4
|
||||
arch=('armv7h')
|
||||
|
@ -12,22 +12,22 @@ url="https://github.com/linux-sunxi/u-boot-sunxi/tree/sunxi-current"
|
|||
license=('GPL')
|
||||
makedepends=('sunxi-tools')
|
||||
backup=(boot/uEnv.txt)
|
||||
_commit=660aa6fd9e1c25baabfcf4dfce42381547f5f59b
|
||||
_commit=765936d2c8ebf048b9c147fc981beccd115c6158
|
||||
source=("https://github.com/linux-sunxi/u-boot-sunxi/archive/${_commit}.tar.gz"
|
||||
'alarm.patch'
|
||||
'cubieboard2.fex' 'cubieboard2.env'
|
||||
'cubietruck.fex' 'cubietruck.env'
|
||||
'iteaduino_plus_a10.fex' 'iteaduino_plus_a10.env'
|
||||
'iteaduino_plus_a20.fex' 'iteaduino_plus_a20.env' )
|
||||
md5sums=('019e2a420fa9d9a5e24aaf9cd8de2104'
|
||||
'f2f60fca0d93ef62c6a95c4f3254a829'
|
||||
md5sums=('8e4f2a2c1384f31eca5d3864b86e8351'
|
||||
'd14a621663c56d37251a3d42d1d10236'
|
||||
'36c04988cecd53151f3f5ff5c48d76a9'
|
||||
'd41d8cd98f00b204e9800998ecf8427e'
|
||||
'c898ab1b57f474d620f5704b2a53d87c'
|
||||
'd41d8cd98f00b204e9800998ecf8427e'
|
||||
'aa401a14c409347842040592d58e7f80'
|
||||
'1bd3355ad6c6c6976c664223958db3f4'
|
||||
'd41d8cd98f00b204e9800998ecf8427e'
|
||||
'f68d14c13b934a66a3f951bc3bd59f3b'
|
||||
'4b85ce18f33c9b4a6338fa973df44f54'
|
||||
'd41d8cd98f00b204e9800998ecf8427e')
|
||||
|
||||
prepare() {
|
||||
|
@ -42,10 +42,11 @@ build() {
|
|||
unset CXXFLAGS
|
||||
unset LDFLAGS
|
||||
|
||||
for i in Cubieboard2 Cubietruck; do
|
||||
for i in Cubieboard2 Cubietruck Iteaduino_Plus_A10 Iteaduino_Plus_A20; do
|
||||
mkdir ../bin_${i}
|
||||
make distclean
|
||||
make ${i}
|
||||
make ${i}_config
|
||||
make
|
||||
mv u-boot-sunxi-with-spl.bin ../bin_${i}
|
||||
done
|
||||
}
|
||||
|
@ -80,7 +81,7 @@ package_uboot-iteaduino_plus_a10() {
|
|||
conflicts=('uboot-cubieboard2' 'uboot-cubietruck' 'uboot-iteaduino_plus_a20')
|
||||
|
||||
mkdir -p "${pkgdir}"/boot
|
||||
cp bin_iteaduino_plus_a10/u-boot-sunxi-with-spl.bin "${pkgdir}"/boot
|
||||
cp bin_Iteaduino_Plus_A10/u-boot-sunxi-with-spl.bin "${pkgdir}"/boot
|
||||
|
||||
fex2bin iteaduino_plus_a10.fex "${pkgdir}"/boot/script.bin
|
||||
cp iteaduino_plus_a10.env "${pkgdir}"/boot/uEnv.txt
|
||||
|
@ -92,7 +93,7 @@ package_uboot-iteaduino_plus_a20() {
|
|||
conflicts=('uboot-cubieboard2' 'uboot-cubietruck' 'uboot-iteaduino_plus_a10')
|
||||
|
||||
mkdir -p "${pkgdir}"/boot
|
||||
cp bin_iteaduino_plus_a20/u-boot-sunxi-with-spl.bin "${pkgdir}"/boot
|
||||
cp bin_Iteaduino_Plus_A20/u-boot-sunxi-with-spl.bin "${pkgdir}"/boot
|
||||
|
||||
fex2bin iteaduino_plus_a20.fex "${pkgdir}"/boot/script.bin
|
||||
cp iteaduino_plus_a20.env "${pkgdir}"/boot/uEnv.txt
|
||||
|
|
|
@ -58,20 +58,3 @@ index a0c41ac..e9a94f6 100644
|
|||
";then true; else "\
|
||||
"false" \
|
||||
";fi" \
|
||||
@@ -272,7 +262,7 @@
|
||||
"\0" \
|
||||
""
|
||||
|
||||
-#define CONFIG_BOOTDELAY 3
|
||||
+#define CONFIG_BOOTDELAY 1
|
||||
#define CONFIG_SYS_BOOT_GET_CMDLINE
|
||||
#define CONFIG_AUTO_COMPLETE
|
||||
|
||||
@@ -287,6 +277,7 @@
|
||||
#define CONFIG_FAT_WRITE /* enable write access */
|
||||
#define CONFIG_CMD_EXT2 /* with this we can access ext2 bootfs */
|
||||
#define CONFIG_CMD_EXT4 /* with this we can access ext4 bootfs */
|
||||
+#define CONFIG_CMD_FS_GENERIC
|
||||
|
||||
#define CONFIG_SPL_FRAMEWORK
|
||||
#define CONFIG_SPL_LIBCOMMON_SUPPORT
|
||||
|
|
File diff suppressed because one or more lines are too long
File diff suppressed because one or more lines are too long
Loading…
Reference in a new issue