PKGBUILDs/extra/boost/4994-compile-fix-for-Python32-v2.patch
2011-03-09 01:42:42 -05:00

17 lines
574 B
Diff

Index: libs/python/src/converter/builtin_converters.cpp
===================================================================
--- libs/python/src/converter/builtin_converters.cpp (revision 67279)
+++ libs/python/src/converter/builtin_converters.cpp (working copy)
@@ -431,7 +431,11 @@
if (!result.empty())
{
int err = PyUnicode_AsWideChar(
+#if PY_VERSION_HEX >= 0x03020000
+ intermediate
+#else
(PyUnicodeObject *)intermediate
+#endif
, &result[0]
, result.size());