mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
24 lines
661 B
Diff
24 lines
661 B
Diff
diff --git a/internal.h b/internal.h
|
|
index 433ab6635d..a4f7e9bde3 100644
|
|
--- a/internal.h
|
|
+++ b/internal.h
|
|
@@ -941,19 +941,9 @@ struct rb_subclass_entry {
|
|
rb_subclass_entry_t *next;
|
|
};
|
|
|
|
-#if defined(HAVE_LONG_LONG)
|
|
-typedef unsigned LONG_LONG rb_serial_t;
|
|
-#define SERIALT2NUM ULL2NUM
|
|
-#define PRI_SERIALT_PREFIX PRI_LL_PREFIX
|
|
-#elif defined(HAVE_UINT64_T)
|
|
-typedef uint64_t rb_serial_t;
|
|
-#define SERIALT2NUM SIZET2NUM
|
|
-#define PRI_SERIALT_PREFIX PRI_64_PREFIX
|
|
-#else
|
|
typedef unsigned long rb_serial_t;
|
|
#define SERIALT2NUM ULONG2NUM
|
|
#define PRI_SERIALT_PREFIX PRI_LONG_PREFIX
|
|
-#endif
|
|
|
|
struct rb_classext_struct {
|
|
struct st_table *iv_index_tbl;
|