mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
64 lines
1.9 KiB
Diff
64 lines
1.9 KiB
Diff
From 8c0c87b338851e3085951b5be47f9ffd96dbac71 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Wed, 16 Mar 2016 20:06:42 -0600
|
|
Subject: [PATCH] arch linux arm modifications
|
|
|
|
---
|
|
configs/omap4_panda_defconfig | 6 +++++-
|
|
include/configs/ti_omap4_common.h | 5 ++---
|
|
2 files changed, 7 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configs/omap4_panda_defconfig b/configs/omap4_panda_defconfig
|
|
index a5fbf9a..6a2da38 100644
|
|
--- a/configs/omap4_panda_defconfig
|
|
+++ b/configs/omap4_panda_defconfig
|
|
@@ -10,6 +10,10 @@ CONFIG_VERSION_VARIABLE=y
|
|
CONFIG_SPL=y
|
|
CONFIG_SPL_OS_BOOT=y
|
|
CONFIG_HUSH_PARSER=y
|
|
+CONFIG_AUTOBOOT_KEYED=y
|
|
+CONFIG_AUTOBOOT_PROMPT="Press SPACE to abort autoboot in %d seconds\n"
|
|
+CONFIG_AUTOBOOT_DELAY_STR="d"
|
|
+CONFIG_AUTOBOOT_STOP_STR=" "
|
|
CONFIG_CMD_BOOTZ=y
|
|
# CONFIG_CMD_IMLS is not set
|
|
CONFIG_CMD_ASKENV=y
|
|
@@ -26,10 +30,10 @@ CONFIG_CMD_MII=y
|
|
CONFIG_CMD_PING=y
|
|
CONFIG_CMD_EXT2=y
|
|
CONFIG_CMD_EXT4=y
|
|
-CONFIG_CMD_EXT4_WRITE=y
|
|
CONFIG_CMD_FAT=y
|
|
CONFIG_CMD_FS_GENERIC=y
|
|
CONFIG_SYS_NS16550=y
|
|
CONFIG_USB=y
|
|
CONFIG_USB_STORAGE=y
|
|
CONFIG_OF_LIBFDT=y
|
|
+CONFIG_IDENT_STRING=" Arch Linux ARM"
|
|
diff --git a/include/configs/ti_omap4_common.h b/include/configs/ti_omap4_common.h
|
|
index 3d2992f..a1dd6e1 100644
|
|
--- a/include/configs/ti_omap4_common.h
|
|
+++ b/include/configs/ti_omap4_common.h
|
|
@@ -42,7 +42,7 @@
|
|
* the timings to use or use pre-determined timings (based on using the
|
|
* dynamic method. Default to the static timing infomation.
|
|
*/
|
|
-#define CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS
|
|
+/*#define CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS*/
|
|
#ifndef CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS
|
|
#define CONFIG_SYS_AUTOMATIC_SDRAM_DETECTION
|
|
#define CONFIG_SYS_DEFAULT_LPDDR2_TIMINGS
|
|
@@ -91,9 +91,8 @@
|
|
|
|
#define BOOT_TARGET_DEVICES(func) \
|
|
func(MMC, mmc, 0) \
|
|
- func(LEGACY_MMC, legacy_mmc, 0) \
|
|
func(MMC, mmc, 1) \
|
|
- func(LEGACY_MMC, legacy_mmc, 1) \
|
|
+ func(USB, usb, 0) \
|
|
func(PXE, pxe, na) \
|
|
func(DHCP, dhcp, na)
|
|
|
|
--
|
|
2.10.2
|
|
|