PKGBUILDs/core/mkinitcpio/0002-functions-handle-gzip-compressed-kernels-in-kver_gen.patch
2022-12-10 01:25:14 +00:00

30 lines
780 B
Diff

From efe14b76219f065b99983f305ac0d71e8c8658a4 Mon Sep 17 00:00:00 2001
From: Janne Grunau <j@jannau.net>
Date: Sun, 30 Jan 2022 10:01:43 +0000
Subject: [PATCH 2/2] functions: handle gzip compressed kernels in kver_generic
Signed-off-by: Janne Grunau <j@jannau.net>
---
functions | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/functions b/functions
index 9939e25..7e58d57 100644
--- a/functions
+++ b/functions
@@ -222,6 +222,11 @@ kver_generic() {
read _ _ kver _ < <($reader "$1" | grep -m1 -aoE 'Linux version .(\.[-[:alnum:]+]+)+')
+ # try if the image is gzip compressed
+ if [[ -z "$kver" ]]; then
+ read _ _ kver _ < <(gzip -c -d "$1" | grep -m1 -aoE 'Linux version .(\.[-[:alnum:]]+)+')
+ fi
+
printf '%s' "$kver"
}
--
2.36.1