PKGBUILDs/extra/pyqt5/pyqt-qt5.8.patch
2017-01-29 00:25:13 +00:00

36 lines
1.6 KiB
Diff

diff -ru a/sip/QtCore/qnamespace.sip b/sip/QtCore/qnamespace.sip
--- a/sip/QtCore/qnamespace.sip 2016-12-25 18:56:11.000000000 +0100
+++ b/sip/QtCore/qnamespace.sip 2017-01-24 12:22:19.025652899 +0100
@@ -209,8 +209,6 @@
WindowContextHelpButtonHint,
WindowShadeButtonHint,
WindowStaysOnTopHint,
- WindowOkButtonHint,
- WindowCancelButtonHint,
WindowStaysOnBottomHint,
WindowCloseButtonHint,
MacWindowToolBarButtonHint,
@@ -232,6 +230,10 @@
%If (Qt_5_5_0 -)
MaximizeUsingFullscreenGeometryHint,
%End
+%If (- Qt_5_8_0)
+ WindowOkButtonHint,
+ WindowCancelButtonHint,
+%End
};
typedef QFlags<Qt::WindowType> WindowFlags;
diff -ru a/sip/QtCore/QtCoremod.sip b/sip/QtCore/QtCoremod.sip
--- a/sip/QtCore/QtCoremod.sip 2016-12-25 18:56:11.000000000 +0100
+++ b/sip/QtCore/QtCoremod.sip 2017-01-24 12:03:50.707514377 +0100
@@ -22,7 +22,7 @@
%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", use_limited_api=True)
-%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1}
+%Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0}
%Platforms {WS_X11 WS_WIN WS_MACX}