PKGBUILDs/alarm/uboot-odroid-c2/0004-arch-linux-arm-modifications.patch
2016-02-27 00:54:13 +00:00

45 lines
1.2 KiB
Diff

From 1c175a4cfda5cf7c783bb0a43481b8f8d821d9bd Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Wed, 3 Feb 2016 21:23:59 -0700
Subject: [PATCH 4/4] arch linux arm modifications
---
common/cmd_cfgload.c | 2 +-
include/configs/odroidc2.h | 7 +++++++
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/common/cmd_cfgload.c b/common/cmd_cfgload.c
index 6774e37..bb08f96 100644
--- a/common/cmd_cfgload.c
+++ b/common/cmd_cfgload.c
@@ -52,7 +52,7 @@ static char* read_cfgload(void)
setenv("filesize", "0");
- sprintf(cmd, "fatload mmc 0:1 0x%p boot.ini", (void *)p);
+ sprintf(cmd, "load mmc 0:1 0x%p /boot/boot.ini", (void *)p);
run_command(cmd, 0);
filesize = getenv_ulong("filesize", 16, 0);
diff --git a/include/configs/odroidc2.h b/include/configs/odroidc2.h
index 74da65d..a03d388 100644
--- a/include/configs/odroidc2.h
+++ b/include/configs/odroidc2.h
@@ -75,6 +75,13 @@
#define CONFIG_BOOTDELAY 1 // Seconds
#define CONFIG_ABORTBOOT_WITH_ENTERKEY
+/* Arch Linux ARM */
+#define CONFIG_CMD_FS_GENERIC
+#define CONFIG_SUPPORT_RAW_INITRD
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
+#define CONFIG_CMD_PART
+#define CONFIG_PARTITION_UUIDS
+
/* args/envs */
#define CONFIG_SYS_MAXARGS 64
--
2.7.1