mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
52 lines
1.2 KiB
Diff
52 lines
1.2 KiB
Diff
--- config.default.orig 2011-11-10 21:48:01.000000000 +0100
|
|
+++ config.default 2011-11-10 21:51:58.383221979 +0100
|
|
@@ -6,23 +6,23 @@
|
|
#BACKEND = allegro
|
|
#BACKEND = gdi
|
|
#BACKEND = sdl
|
|
-#BACKEND = mixer_sdl
|
|
+BACKEND = mixer_sdl
|
|
#BACKEND = posix
|
|
|
|
#COLOUR_DEPTH = 0
|
|
-#COLOUR_DEPTH = 16
|
|
+COLOUR_DEPTH = 16
|
|
|
|
#OSTYPE = amiga
|
|
#OSTYPE = beos
|
|
#OSTYPE = cygwin
|
|
#OSTYPE = freebsd
|
|
#OSTYPE = haiku
|
|
-#OSTYPE = linux
|
|
+OSTYPE = linux
|
|
#OSTYPE = mingw
|
|
#OSTYPE = mac
|
|
|
|
#DEBUG = 3 # Level 1-3, higher number means more debug-friendly, see Makefile
|
|
-#OPTIMISE = 1 # Add umpteen optimisation flags
|
|
+OPTIMISE = 1 # Add umpteen optimisation flags
|
|
#PROFILE = 1 # Enable profiling
|
|
#PROFILE = 2 # Enable profiling with optimisation flags, can be used with `OPTIMISE = 1'
|
|
|
|
@@ -34,9 +34,9 @@
|
|
# Define these as empty strings, if you don't have the respective config program
|
|
#ALLEGRO_CONFIG = allegro-config
|
|
#PNG_CONFIG = pkg-config libpng
|
|
-#SDL_CONFIG = sdl-config
|
|
+SDL_CONFIG = sdl-config
|
|
|
|
-#VERBOSE = 1
|
|
+VERBOSE = 1
|
|
|
|
# The following useful conditional compilation flags exist
|
|
#
|
|
@@ -65,6 +65,9 @@
|
|
#
|
|
# In order to use the flags, add a line like this: (-Dxxx)
|
|
# FLAGS = -DUSE_C
|
|
+ifeq ($(shell uname -m),x86_64)
|
|
+ FLAGS += -DUSE_C
|
|
+endif
|
|
|
|
# Output directories:
|
|
#
|