mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
20 lines
354 B
Diff
20 lines
354 B
Diff
ANYARG patch
|
|
|
|
diff --git a/src/pari.cc b/src/pari.cc
|
|
index 76ce8e1..50d08ab 100644
|
|
--- a/src/pari.cc
|
|
+++ b/src/pari.cc
|
|
@@ -40,6 +40,13 @@ using namespace std;
|
|
|
|
#ifdef HAVE_LIBPARI
|
|
|
|
+// Anyarg disappeared from PARI 2.15.0
|
|
+#ifdef __cplusplus
|
|
+# define ANYARG ...
|
|
+#else
|
|
+# define ANYARG
|
|
+#endif
|
|
+
|
|
#ifdef HAVE_PTHREAD_H
|
|
#include <pthread.h>
|
|
#endif
|