mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
69 lines
2 KiB
Diff
69 lines
2 KiB
Diff
From 774ceae7a29cc5492ad6559169fdf7f43c48608e Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Wed, 16 Mar 2016 20:06:42 -0600
|
|
Subject: [PATCH] arch linux arm modifications
|
|
|
|
---
|
|
configs/omap4_panda_defconfig | 5 ++++-
|
|
include/configs/ti_omap4_common.h | 7 ++++---
|
|
2 files changed, 8 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configs/omap4_panda_defconfig b/configs/omap4_panda_defconfig
|
|
index 406f0ac..8f62717 100644
|
|
--- a/configs/omap4_panda_defconfig
|
|
+++ b/configs/omap4_panda_defconfig
|
|
@@ -3,6 +3,10 @@ CONFIG_OMAP44XX=y
|
|
CONFIG_TARGET_OMAP4_PANDA=y
|
|
CONFIG_SPL=y
|
|
CONFIG_HUSH_PARSER=y
|
|
+CONFIG_AUTOBOOT_KEYED=y
|
|
+CONFIG_AUTOBOOT_PROMPT="Press SPACE to abort autoboot in %d seconds\n"
|
|
+CONFIG_AUTOBOOT_DELAY_STR="d"
|
|
+CONFIG_AUTOBOOT_STOP_STR=" "
|
|
CONFIG_CMD_BOOTZ=y
|
|
# CONFIG_CMD_IMLS is not set
|
|
CONFIG_CMD_ASKENV=y
|
|
@@ -19,7 +23,6 @@ CONFIG_CMD_MII=y
|
|
CONFIG_CMD_PING=y
|
|
CONFIG_CMD_EXT2=y
|
|
CONFIG_CMD_EXT4=y
|
|
-CONFIG_CMD_EXT4_WRITE=y
|
|
CONFIG_CMD_FAT=y
|
|
CONFIG_CMD_FS_GENERIC=y
|
|
CONFIG_SYS_NS16550=y
|
|
diff --git a/include/configs/ti_omap4_common.h b/include/configs/ti_omap4_common.h
|
|
index 5fad3c1..8d97f56 100644
|
|
--- a/include/configs/ti_omap4_common.h
|
|
+++ b/include/configs/ti_omap4_common.h
|
|
@@ -12,6 +12,8 @@
|
|
#ifndef __CONFIG_TI_OMAP4_COMMON_H
|
|
#define __CONFIG_TI_OMAP4_COMMON_H
|
|
|
|
+#define CONFIG_IDENT_STRING " Arch Linux ARM"
|
|
+
|
|
/*
|
|
* High Level Configuration Options
|
|
*/
|
|
@@ -45,7 +47,7 @@
|
|
* the timings to use or use pre-determined timings (based on using the
|
|
* dynamic method. Default to the static timing infomation.
|
|
*/
|
|
-#define CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS
|
|
+/*#define CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS*/
|
|
#ifndef CONFIG_SYS_EMIF_PRECALCULATED_TIMING_REGS
|
|
#define CONFIG_SYS_AUTOMATIC_SDRAM_DETECTION
|
|
#define CONFIG_SYS_DEFAULT_LPDDR2_TIMINGS
|
|
@@ -95,9 +97,8 @@
|
|
|
|
#define BOOT_TARGET_DEVICES(func) \
|
|
func(MMC, mmc, 0) \
|
|
- func(LEGACY_MMC, legacy_mmc, 0) \
|
|
func(MMC, mmc, 1) \
|
|
- func(LEGACY_MMC, legacy_mmc, 1) \
|
|
+ func(USB, usb, 0) \
|
|
func(PXE, pxe, na) \
|
|
func(DHCP, dhcp, na)
|
|
|
|
--
|
|
2.9.0
|
|
|