mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
21 lines
657 B
Diff
21 lines
657 B
Diff
Bug: https://bugs.gentoo.org/686982
|
|
|
|
TabStripModelChange has a defaulted default constructor and a const data member
|
|
without a user-defined default constructor. This leads to a bug:
|
|
|
|
error: defaulting this default constructor would delete it after
|
|
its first declaration
|
|
|
|
We declare the data member as non-const instead.
|
|
|
|
--- a/chrome/browser/ui/tabs/tab_strip_model_observer.h
|
|
+++ b/chrome/browser/ui/tabs/tab_strip_model_observer.h
|
|
@@ -103,7 +103,7 @@ class TabStripModelChange {
|
|
|
|
private:
|
|
const Type type_ = kSelectionOnly;
|
|
- const std::vector<Delta> deltas_;
|
|
+ std::vector<Delta> deltas_;
|
|
|
|
DISALLOW_COPY_AND_ASSIGN(TabStripModelChange);
|
|
};
|