mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
51 lines
1.8 KiB
Diff
51 lines
1.8 KiB
Diff
From e81fe84405bc635dfa93e54fb8a3c8e6065dbf10 Mon Sep 17 00:00:00 2001
|
|
From: David Tardon <dtardon@redhat.com>
|
|
Date: Sat, 6 Jun 2015 18:27:24 +0200
|
|
Subject: [PATCH] adapt to libwps 0.4
|
|
|
|
---
|
|
cmake/modules/FindLibWps.cmake | 6 +++---
|
|
filters/words/works/import/WPSImport.cpp | 4 +++-
|
|
2 files changed, 6 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/cmake/modules/FindLibWps.cmake b/cmake/modules/FindLibWps.cmake
|
|
index f8c8225..58ef2b5 100644
|
|
--- a/cmake/modules/FindLibWps.cmake
|
|
+++ b/cmake/modules/FindLibWps.cmake
|
|
@@ -10,16 +10,16 @@
|
|
|
|
include(LibFindMacros)
|
|
libfind_package(LIBWPS LibWpd)
|
|
-libfind_pkg_check_modules(LIBWPS_PKGCONF libwps-0.3)
|
|
+libfind_pkg_check_modules(LIBWPS_PKGCONF libwps-0.4)
|
|
|
|
find_path(LIBWPS_INCLUDE_DIR
|
|
NAMES libwps/libwps.h
|
|
HINTS ${LIBWPS_PKGCONF_INCLUDE_DIRS} ${LIBWPS_PKGCONF_INCLUDEDIR}
|
|
- PATH_SUFFIXES libwps-0.3
|
|
+ PATH_SUFFIXES libwps-0.4
|
|
)
|
|
|
|
find_library(LIBWPS_LIBRARY
|
|
- NAMES wps wps-0.3
|
|
+ NAMES wps wps-0.4
|
|
HINTS ${LIBWPS_PKGCONF_LIBRARY_DIRS} ${LIBWPS_PKGCONF_LIBDIR}
|
|
)
|
|
|
|
diff --git a/filters/words/works/import/WPSImport.cpp b/filters/words/works/import/WPSImport.cpp
|
|
index eea2cc9..94b859d 100644
|
|
--- a/filters/words/works/import/WPSImport.cpp
|
|
+++ b/filters/words/works/import/WPSImport.cpp
|
|
@@ -91,7 +91,9 @@ public:
|
|
bool isSupportedFormat(librevenge::RVNGInputStream &input)
|
|
{
|
|
WPSKind kind = WPS_TEXT;
|
|
- WPSConfidence confidence = WPSDocument::isFileFormatSupported(&input, kind);
|
|
+ WPSCreator creator = WPS_MSWORKS;
|
|
+ bool needsEncoding = false;
|
|
+ WPSConfidence confidence = WPSDocument::isFileFormatSupported(&input, kind, creator, needsEncoding);
|
|
if (confidence == WPS_CONFIDENCE_NONE || kind != WPS_TEXT)
|
|
return false;
|
|
return true;
|
|
--
|
|
2.4.2
|