mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
33 lines
1.2 KiB
Diff
33 lines
1.2 KiB
Diff
diff --git a/build/make/configure.sh b/build/make/configure.sh
|
|
index c99a01c..34f9baf 100755
|
|
--- a/build/make/configure.sh
|
|
+++ b/build/make/configure.sh
|
|
@@ -775,7 +775,6 @@ process_common_toolchain() {
|
|
|
|
case ${tgt_cc} in
|
|
gcc)
|
|
- CROSS=${CROSS:-arm-none-linux-gnueabi-}
|
|
link_with_cc=gcc
|
|
setup_gnu_toolchain
|
|
arch_int=${tgt_isa##armv}
|
|
@@ -783,18 +782,14 @@ process_common_toolchain() {
|
|
check_add_asflags --defsym ARCHITECTURE=${arch_int}
|
|
tune_cflags="-mtune="
|
|
if [ ${tgt_isa} == "armv7" ]; then
|
|
- check_add_cflags -march=armv7-a -mfloat-abi=softfp
|
|
- check_add_asflags -march=armv7-a -mfloat-abi=softfp
|
|
+ check_add_cflags -march=armv7-a
|
|
+ check_add_asflags -march=armv7-a
|
|
|
|
if enabled neon
|
|
then
|
|
check_add_cflags -mfpu=neon #-ftree-vectorize
|
|
check_add_asflags -mfpu=neon
|
|
fi
|
|
-
|
|
- if [ -z "${tune_cpu}" ]; then
|
|
- tune_cpu=cortex-a8
|
|
- fi
|
|
else
|
|
check_add_cflags -march=${tgt_isa}
|
|
check_add_asflags -march=${tgt_isa}
|