mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
23 lines
1.1 KiB
Diff
23 lines
1.1 KiB
Diff
unittests/linuxliketests.py | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git c/unittests/linuxliketests.py i/unittests/linuxliketests.py
|
|
index 81cca06dd..88b49b63e 100644
|
|
--- c/unittests/linuxliketests.py
|
|
+++ i/unittests/linuxliketests.py
|
|
@@ -343,6 +343,7 @@ class LinuxlikeTests(BasePlatformTests):
|
|
raise SkipTest('asan not available on Cygwin')
|
|
if is_openbsd():
|
|
raise SkipTest('-fsanitize=address is not supported on OpenBSD')
|
|
+ raise SkipTest('cannot run sanitizers in containers without ptrace')
|
|
|
|
testdir = os.path.join(self.framework_test_dir, '7 gnome')
|
|
self.init(testdir, extra_args=['-Db_sanitize=address', '-Db_lundef=false'])
|
|
@@ -974,6 +975,7 @@ class LinuxlikeTests(BasePlatformTests):
|
|
raise SkipTest('asan not available on Cygwin')
|
|
if is_openbsd():
|
|
raise SkipTest('-fsanitize=address is not supported on OpenBSD')
|
|
+ raise SkipTest('cannot run sanitizers in containers without ptrace')
|
|
|
|
testdir = os.path.join(self.common_test_dir, '13 pch')
|
|
self.init(testdir, extra_args=['-Db_sanitize=address', '-Db_lundef=false'])
|