mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
72 lines
2.2 KiB
Diff
72 lines
2.2 KiB
Diff
From aff7d41d285c04f5990247660c860e30029f72b2 Mon Sep 17 00:00:00 2001
|
|
From: Konstantin Porotchkin <kostap@marvell.com>
|
|
Date: Tue, 23 May 2017 16:11:40 +0300
|
|
Subject: [PATCH 05/11] arm64: dts: marvell: Enable second SDHCI controller in
|
|
Armada 37xx
|
|
|
|
The Armada 37xx SoCs has 2 SDHCI interfaces. This patch adds the second
|
|
one.
|
|
|
|
Moreover, the Armada 37xx DB v2 board populates the 2 SDHCI interfaces.
|
|
|
|
The second interface is using pluggable module that can either
|
|
have an SD connector or eMMC on it.
|
|
This patch adds support for SD module in the device DT.
|
|
|
|
[ gregory.clement@free-electrons.com:
|
|
- Add more detail in commit log
|
|
- Sort the dt node in address order
|
|
- Document the SD slot in the dts ]
|
|
|
|
Signed-off-by: Konstantin Porotchkin <kostap@marvell.com>
|
|
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
|
|
---
|
|
arch/arm64/boot/dts/marvell/armada-3720-db.dts | 9 +++++++++
|
|
arch/arm64/boot/dts/marvell/armada-37xx.dtsi | 11 +++++++++++
|
|
2 files changed, 20 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/marvell/armada-3720-db.dts b/arch/arm64/boot/dts/marvell/armada-3720-db.dts
|
|
index a89855f57091..6a0abd7a5349 100644
|
|
--- a/arch/arm64/boot/dts/marvell/armada-3720-db.dts
|
|
+++ b/arch/arm64/boot/dts/marvell/armada-3720-db.dts
|
|
@@ -113,6 +113,15 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+/* SD slot module on CON14(V2.0)/CON15(V1.4) */
|
|
+&sdhci1 {
|
|
+ wp-inverted;
|
|
+ cd-gpios = <&gpiosb 2 GPIO_ACTIVE_LOW>;
|
|
+ bus-width = <4>;
|
|
+ marvell,pad-type = "sd";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&spi0 {
|
|
status = "okay";
|
|
pinctrl-names = "default";
|
|
diff --git a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
|
index f4deb8cd11c6..a78195b4ef7a 100644
|
|
--- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
|
+++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
|
@@ -293,6 +293,17 @@
|
|
};
|
|
};
|
|
|
|
+ sdhci1: sdhci@d0000 {
|
|
+ compatible = "marvell,armada-3700-sdhci",
|
|
+ "marvell,sdhci-xenon";
|
|
+ reg = <0xd0000 0x300>,
|
|
+ <0x1e808 0x4>;
|
|
+ interrupts = <GIC_SPI 25 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ clocks = <&nb_periph_clk 0>;
|
|
+ clock-names = "core";
|
|
+ status = "disabled";
|
|
+ };
|
|
+
|
|
sdhci0: sdhci@d8000 {
|
|
compatible = "marvell,armada-3700-sdhci",
|
|
"marvell,sdhci-xenon";
|
|
--
|
|
2.13.3
|
|
|