mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
40 lines
1.1 KiB
Diff
40 lines
1.1 KiB
Diff
From 79fe90b4616ad226f1329c7754fc2745dc5139af Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Sun, 29 Jan 2017 11:07:56 -0700
|
|
Subject: [PATCH] AArch64 fixes
|
|
|
|
---
|
|
libco/sjlj.c | 2 ++
|
|
nall/intrinsics.hpp | 2 +-
|
|
2 files changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/libco/sjlj.c b/libco/sjlj.c
|
|
index dfa0aa45..34e4b3c1 100644
|
|
--- a/libco/sjlj.c
|
|
+++ b/libco/sjlj.c
|
|
@@ -10,7 +10,9 @@
|
|
*/
|
|
|
|
#define LIBCO_C
|
|
+#define _XOPEN_SOURCE 700
|
|
#include "libco.h"
|
|
+#include "settings.h"
|
|
|
|
#include <stdlib.h>
|
|
#include <signal.h>
|
|
diff --git a/nall/intrinsics.hpp b/nall/intrinsics.hpp
|
|
index e5dcaf64..20ed3460 100644
|
|
--- a/nall/intrinsics.hpp
|
|
+++ b/nall/intrinsics.hpp
|
|
@@ -122,7 +122,7 @@ namespace nall {
|
|
#elif defined(__amd64__) || defined(_M_AMD64)
|
|
#define PROCESSOR_AMD64
|
|
auto Intrinsics::processor() -> Processor { return Processor::amd64; }
|
|
-#elif defined(__arm__)
|
|
+#elif defined(__arm__) || defined(__aarch64__)
|
|
#define PROCESSOR_ARM
|
|
auto Intrinsics::processor() -> Processor { return Processor::ARM; }
|
|
#elif defined(__ppc64__) || defined(_ARCH_PPC64)
|
|
--
|
|
2.11.0
|
|
|