PKGBUILDs/community/xulrunner/sed43.patch
2017-04-29 16:35:29 +00:00

22 lines
966 B
Diff

# HG changeset patch
# User Daniel Stenberg <daniel@haxx.se>
# Date 1484000700 -3600
# Node ID ebcbf47a83e7d3b89460cf1c991b6be5a79a967b
# Parent 0759511f24e1b8d42acf5e9612f3ab91715842c2
Bug 1329272 - add bracket for sed 4.3 compliance, r=glandium
diff --git a/build/autoconf/icu.m4 b/build/autoconf/icu.m4
--- a/build/autoconf/icu.m4
+++ b/build/autoconf/icu.m4
@@ -69,7 +69,7 @@ if test -n "$USE_ICU"; then
fi
fi
- version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
+ version=`sed -n 's/^[[[:space:]]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
if test x"$version" = x; then
AC_MSG_ERROR([cannot determine icu version number from uvernum.h header file $lineno])
fi