mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
14 lines
703 B
Diff
14 lines
703 B
Diff
Patch from Steve Langasek to fix unused vs. used gcc attribute on arm.
|
|
bz#307418
|
|
--- a/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp
|
|
+++ b/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp
|
|
@@ -45,7 +45,8 @@
|
|
#endif
|
|
|
|
/* Specify explicitly a symbol for this function, don't try to guess the c++ mangled symbol. */
|
|
-static nsresult PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args) asm("_PrepareAndDispatch");
|
|
+static nsresult PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args) asm("_PrepareAndDispatch")
|
|
+__attribute__((used));
|
|
|
|
static nsresult
|
|
PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args)
|