mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
64 lines
2.7 KiB
Diff
64 lines
2.7 KiB
Diff
From 5679c3c191ed62b62d8db22f1657a296ee9bfe8e Mon Sep 17 00:00:00 2001
|
|
From: Frank Tang <ftang@chromium.org>
|
|
Date: Wed, 30 Oct 2019 22:49:47 +0000
|
|
Subject: [PATCH] Update ICU to 65.1 from 64 and fix broken tests
|
|
|
|
ICU 65-1 release note
|
|
http://site.icu-project.org/download/65
|
|
|
|
CLDR 36 release blog
|
|
http://blog.unicode.org/2019/10/unicode-cldr-version-36-languagelocale.html
|
|
|
|
Most of the test expectation change is due to CLDR 36 update
|
|
of Grapheme Cluster for Indic languages
|
|
See the following for related changes in ICU 65.1 in this area:
|
|
https://unicode-org.atlassian.net/browse/CLDR-10994
|
|
https://unicode-org.atlassian.net/browse/ICU-13637
|
|
https://github.com/unicode-org/cldr/blob/master/common/properties/segments/readme.txt
|
|
|
|
Bug: chromium:1014272, chromium:1017047
|
|
Change-Id: I9fc6d4620bf2a4c189940d06d8c79893502db3dd
|
|
Cq-Include-Trybots: luci.chromium.try:linux_layout_tests_layout_ng_disabled
|
|
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/1866059
|
|
Reviewed-by: Jungshik Shin <jshin@chromium.org>
|
|
Reviewed-by: Doug Turner <dougt@chromium.org>
|
|
Reviewed-by: Michael Wasserman <msw@chromium.org>
|
|
Reviewed-by: Kent Tamura <tkent@chromium.org>
|
|
Reviewed-by: Trent Apted <tapted@chromium.org>
|
|
Reviewed-by: Mason Freed <masonfreed@chromium.org>
|
|
Commit-Queue: Frank Tang <ftang@chromium.org>
|
|
Cr-Commit-Position: refs/heads/master@{#711027}
|
|
---
|
|
third_party/blink/renderer/core/dom/document.cc | 2 +-
|
|
ui/gfx/render_text_harfbuzz.cc | 5 ++++-
|
|
2 files changed, 5 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/third_party/blink/renderer/core/dom/document.cc b/third_party/blink/renderer/core/dom/document.cc
|
|
index 511aac29086..f188cf548a6 100644
|
|
--- a/third_party/blink/renderer/core/dom/document.cc
|
|
+++ b/third_party/blink/renderer/core/dom/document.cc
|
|
@@ -6191,7 +6191,7 @@ static ParseQualifiedNameResult ParseQualifiedNameInternal(
|
|
|
|
for (unsigned i = 0; i < length;) {
|
|
UChar32 c;
|
|
- U16_NEXT(characters, i, length, c)
|
|
+ U16_NEXT(characters, i, length, c);
|
|
if (c == ':') {
|
|
if (saw_colon)
|
|
return ParseQualifiedNameResult(kQNMultipleColons);
|
|
diff --git a/ui/gfx/render_text_harfbuzz.cc b/ui/gfx/render_text_harfbuzz.cc
|
|
index 50e86af6b97..0339ff3ff8e 100644
|
|
--- a/ui/gfx/render_text_harfbuzz.cc
|
|
+++ b/ui/gfx/render_text_harfbuzz.cc
|
|
@@ -971,7 +971,10 @@ RangeF TextRunHarfBuzz::GetGraphemeBounds(RenderTextHarfBuzz* render_text,
|
|
++total;
|
|
}
|
|
}
|
|
- DCHECK_GT(total, 0);
|
|
+ // With ICU 65.1, DCHECK_GT() below fails.
|
|
+ // See https://crbug.com/1017047 for more details.
|
|
+ //
|
|
+ // DCHECK_GT(total, 0);
|
|
|
|
// It's possible for |text_index| to point to a diacritical mark, at the end
|
|
// of |chars|. In this case all the grapheme boundaries come before it. Just
|