mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
62 lines
2.1 KiB
Diff
62 lines
2.1 KiB
Diff
From d2c0d2c702b3847a0b1bf06996998c142254952e Mon Sep 17 00:00:00 2001
|
|
From: Andreas Kemnade <andreas@kemnade.info>
|
|
Date: Mon, 22 Aug 2016 21:24:22 +0200
|
|
Subject: [PATCH 12/13] phy-twl4030-usb: better handle musb_mailbox() failure
|
|
|
|
setting twl->linkstat = MUSB_UNKNOWN upon error in musb_mailbox as
|
|
introduced in
|
|
commit 12b7db2bf8b8 ("usb: musb: Return error value from musb_mailbox")
|
|
causes twl4030_usb_irq() to not detect a state change form cable connected
|
|
to cable disconnected after such an error so that
|
|
pm_runtime_put_autosuspend() will not be called and the usage counter
|
|
gets unbalanced. Such errors happen e.g. if the omap2430 module is not
|
|
(yet) loaded during plug/unplug events.
|
|
|
|
This patch introduces a flag instead that indicates whether there is
|
|
information for the musb_mailbox pending and calls musb_mailbox() if
|
|
that flag is set.
|
|
|
|
Signed-off-by: Andreas Kemnade <andreas@kemnade.info>
|
|
Tested-by: Tony Lindgren <tony@atomide.com>
|
|
---
|
|
drivers/phy/phy-twl4030-usb.c | 9 +++++++--
|
|
1 file changed, 7 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/drivers/phy/phy-twl4030-usb.c b/drivers/phy/phy-twl4030-usb.c
|
|
index d9b10a3..81067b4 100644
|
|
--- a/drivers/phy/phy-twl4030-usb.c
|
|
+++ b/drivers/phy/phy-twl4030-usb.c
|
|
@@ -172,6 +172,7 @@ struct twl4030_usb {
|
|
int irq;
|
|
enum musb_vbus_id_status linkstat;
|
|
bool vbus_supplied;
|
|
+ bool musb_mailbox_pending;
|
|
|
|
struct delayed_work id_workaround_work;
|
|
};
|
|
@@ -569,9 +570,12 @@ static irqreturn_t twl4030_usb_irq(int irq, void *_twl)
|
|
pm_runtime_mark_last_busy(twl->dev);
|
|
pm_runtime_put_autosuspend(twl->dev);
|
|
}
|
|
+ twl->musb_mailbox_pending = true;
|
|
+ }
|
|
+ if (twl->musb_mailbox_pending) {
|
|
err = musb_mailbox(status);
|
|
- if (err)
|
|
- twl->linkstat = MUSB_UNKNOWN;
|
|
+ if (!err)
|
|
+ twl->musb_mailbox_pending = false;
|
|
}
|
|
|
|
/* don't schedule during sleep - irq works right then */
|
|
@@ -676,6 +680,7 @@ static int twl4030_usb_probe(struct platform_device *pdev)
|
|
twl->irq = platform_get_irq(pdev, 0);
|
|
twl->vbus_supplied = false;
|
|
twl->linkstat = MUSB_UNKNOWN;
|
|
+ twl->musb_mailbox_pending = false;
|
|
|
|
twl->phy.dev = twl->dev;
|
|
twl->phy.label = "twl4030";
|
|
--
|
|
2.10.2
|
|
|