mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
11 lines
436 B
Diff
11 lines
436 B
Diff
--- a/include/dwarf_i.h
|
|
+++ b/include/dwarf_i.h
|
|
@@ -20,7 +20,7 @@
|
|
extern const uint8_t dwarf_to_unw_regnum_map[DWARF_REGNUM_MAP_LENGTH];
|
|
/* REG is evaluated multiple times; it better be side-effects free! */
|
|
# define dwarf_to_unw_regnum(reg) \
|
|
- (((reg) <= DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
|
|
+ (((reg) < DWARF_REGNUM_MAP_LENGTH) ? dwarf_to_unw_regnum_map[reg] : 0)
|
|
#endif
|
|
|
|
#ifdef UNW_LOCAL_ONLY
|