PKGBUILDs/extra/qt5-webengine/0001-ARM-toolchain-fixes.patch
2017-06-09 12:23:17 +00:00

73 lines
2 KiB
Diff

From 581e99bdd47340b9b3d41cffd51d8ac03422def6 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 8 Jun 2017 20:41:08 -0600
Subject: [PATCH] ARM toolchain fixes
---
chromium/build/toolchain/linux/BUILD.gn | 20 +++++++++++++++++++-
chromium/tools/gn/args.cc | 3 +++
2 files changed, 22 insertions(+), 1 deletion(-)
diff --git a/chromium/build/toolchain/linux/BUILD.gn b/chromium/build/toolchain/linux/BUILD.gn
index 548722d393..8a24c50f79 100644
--- a/chromium/build/toolchain/linux/BUILD.gn
+++ b/chromium/build/toolchain/linux/BUILD.gn
@@ -22,7 +22,7 @@ clang_toolchain("clang_arm64") {
}
gcc_toolchain("arm") {
- toolprefix = "arm-linux-gnueabihf-"
+ toolprefix = ""
cc = "${toolprefix}gcc"
cxx = "${toolprefix}g++"
@@ -39,6 +39,24 @@ gcc_toolchain("arm") {
}
}
+gcc_toolchain("arm64") {
+ toolprefix = ""
+
+ cc = "${toolprefix}gcc"
+ cxx = "${toolprefix}g++"
+
+ ar = "${toolprefix}ar"
+ ld = cxx
+ readelf = "${toolprefix}readelf"
+ nm = "${toolprefix}nm"
+
+ toolchain_args = {
+ current_cpu = "arm64"
+ current_os = "linux"
+ is_clang = false
+ }
+}
+
clang_toolchain("clang_x86") {
toolchain_args = {
current_cpu = "x86"
diff --git a/chromium/tools/gn/args.cc b/chromium/tools/gn/args.cc
index 7285d7a538..54703e1760 100644
--- a/chromium/tools/gn/args.cc
+++ b/chromium/tools/gn/args.cc
@@ -266,6 +266,7 @@ void Args::SetSystemVarsLocked(Scope* dest) const {
static const char kX86[] = "x86";
static const char kX64[] = "x64";
static const char kArm[] = "arm";
+ static const char kArm64[] = "arm64";
static const char kMips[] = "mipsel";
static const char kS390X[] = "s390x";
static const char kPPC64[] = "ppc64";
@@ -280,6 +281,8 @@ void Args::SetSystemVarsLocked(Scope* dest) const {
arch = kX64;
else if (os_arch.substr(0, 3) == "arm")
arch = kArm;
+ else if (os_arch == "aarch64")
+ arch = kArm64;
else if (os_arch == "mips")
arch = kMips;
else if (os_arch == "s390x")
--
2.12.0