PKGBUILDs/extra/vlc/vlc-3.0.11.1-srt_1.4.2.patch
2020-10-02 01:40:34 +00:00

25 lines
1,022 B
Diff

diff -ruN a/modules/access/srt.c b/modules/access/srt.c
--- a/modules/access/srt.c 2018-04-23 10:03:39.000000000 +0200
+++ b/modules/access/srt.c 2020-09-26 10:35:18.830149487 +0200
@@ -165,7 +165,7 @@
/* Set latency */
i_latency = var_InheritInteger( p_stream, "latency" );
- srt_setsockopt( p_sys->sock, 0, SRTO_TSBPDDELAY,
+ srt_setsockopt( p_sys->sock, 0, SRTO_LATENCY,
&i_latency, sizeof( int ) );
psz_passphrase = var_InheritString( p_stream, "passphrase" );
diff -ruN a/modules/access_output/srt.c b/modules/access_output/srt.c
--- a/modules/access_output/srt.c 2018-04-06 11:22:51.000000000 +0200
+++ b/modules/access_output/srt.c 2020-09-26 10:35:03.386828120 +0200
@@ -162,7 +162,7 @@
/* Set latency */
i_latency = var_InheritInteger( p_access, "latency" );
- srt_setsockopt( p_sys->sock, 0, SRTO_TSBPDDELAY,
+ srt_setsockopt( p_sys->sock, 0, SRTO_LATENCY,
&i_latency, sizeof( int ) );
if ( psz_passphrase != NULL && psz_passphrase[0] != '\0')