mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
38 lines
1.1 KiB
Diff
38 lines
1.1 KiB
Diff
diff -urN a/CMakeLists.txt b/CMakeLists.txt
|
|
--- a/CMakeLists.txt 2015-01-26 03:44:19.000000000 -0700
|
|
+++ b/CMakeLists.txt 2015-01-27 06:00:42.290677955 -0700
|
|
@@ -392,10 +392,6 @@
|
|
)
|
|
endif()
|
|
|
|
-if(KWIN_HAVE_EGL)
|
|
- set(kwin_KDEINIT_SRCS ${kwin_KDEINIT_SRCS} eglonxbackend.cpp)
|
|
-endif()
|
|
-
|
|
if(HAVE_WAYLAND)
|
|
set(kwin_KDEINIT_SRCS
|
|
${kwin_KDEINIT_SRCS}
|
|
diff -urN a/scene_opengl.cpp b/scene_opengl.cpp
|
|
--- a/scene_opengl.cpp 2015-01-26 03:27:31.000000000 -0700
|
|
+++ b/scene_opengl.cpp 2015-01-27 06:00:42.295677953 -0700
|
|
@@ -28,7 +28,6 @@
|
|
*********************************************************************/
|
|
#include "scene_opengl.h"
|
|
#ifdef KWIN_HAVE_EGL
|
|
-#include "eglonxbackend.h"
|
|
// for Wayland
|
|
#if HAVE_WAYLAND_EGL
|
|
#include "egl_wayland_backend.h"
|
|
@@ -488,10 +487,10 @@
|
|
if (kwinApp()->shouldUseWaylandForCompositing()) {
|
|
backend = new EglWaylandBackend();
|
|
} else {
|
|
- backend = new EglOnXBackend();
|
|
+ backend = NULL;
|
|
}
|
|
#else
|
|
- backend = new EglOnXBackend();
|
|
+ backend = NULL;
|
|
#endif
|
|
#endif
|
|
break;
|