mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
12 lines
583 B
Diff
12 lines
583 B
Diff
diff --git a/src/widgets/kernel/qwidget.cpp b/src/widgets/kernel/qwidget.cpp
|
|
index 04290a4ce1..27773d5762 100644
|
|
--- a/src/widgets/kernel/qwidget.cpp
|
|
+++ b/src/widgets/kernel/qwidget.cpp
|
|
@@ -6446,7 +6446,7 @@ void QWidget::setFocusProxy(QWidget * w)
|
|
|
|
if (changingAppFocusWidget) {
|
|
QWidget *newDeepestFocusProxy = d_func()->deepestFocusProxy();
|
|
- QApplicationPrivate::focus_widget = newDeepestFocusProxy ? newDeepestFocusProxy : this;
|
|
+ QApplicationPrivate::setFocusWidget(newDeepestFocusProxy ? newDeepestFocusProxy : this, Qt::NoFocusReason);
|
|
}
|
|
}
|